Topic: touch zoom and markers

I'm building an app based on the popups example. Everything works perfectly in editor play mode with mouse control, or using a mouse with a Windows build. But When I use zoom with pinching touch gesture the map zooms perfectly but the markers start freaking out. The markers disappear or appear in the wrong place, then snap back to where they should be when I move around the map. There seems to be a particular place on the map, over North America where problems tend to happen. If I pinch zoom over Asia things work. This experience the problem with multiple Android devices and a touch screen Windows PC.

details:
I used the popup example as a base, most of the scripts were directly lifted from there. I'm not using multiple camera angles or the on screen UI zoom tool.

I'm using the Bing map. Size and size in scene are both 1024 by 1024 (I haven't changed these from the example scene).

-------------------------
Another issue:
Far less important than the above, but still mysterious. Popup don't show up when the map is zoomed all the way out. If I'm on the widest zoom and touch a popup I don't see it, but if I zoom in a little it magically appears.

Thanks for the help!

Re: touch zoom and markers

Hello.

I will start with the second problem:
This is fixed, and in the next version it will work correctly.
If you want to receive a modified script, you can write me an email (support@infinity-code.com), and I will send it to you.

About the first problem:
Unfortunately, I could not reproduce this.
Maybe this was fixed along with the second problem.
Or maybe it requires some additional condition for the problem to appear.

Kind Regards,
Infinity Code Team.

Do not know the best way to thank the developer? Rate the asset in Asset Store!

Re: touch zoom and markers

problem 2- I'll go ahead and email you for that script since you offered and I'm already running into the problem.

Problem 1- I built and tested the popup example and it worked fine so as you said, it must be some modification I made. I'm going to replace and test things one at a time until I run into the problem. I'll report back when I find something.

Re: touch zoom and markers

Looks like I got it.

I updated to the lastest version of the asset and hit "reimport all" and now problem 1 is gone.