Topic: Black map on restart

Hi,

I'm having a weird issue. On iOS, when building and deploying the app for the first time, the map works great (we're using pre-captured tiles from the resources folder), but when the app is restarted, the map shows as black, but the custom markers and GPS works okay. The issue doesn't happen on Android, the map works flawlessly there. I was just wondering if there's a setting or something for iOS that I should be toggling? I have the software JPEG decoder option turned on, and I also clicked on the "Fix import settings for tiles" button.

I'm actually not the one handling the iOS builds for our project, but if you need more info from the developer who does, I can get whatever information you need. Thanks!

Re: Black map on restart

Hello.

I have never heard of such a problem, and I cannot imagine (even theoretically) why this is happening.
If the textures do not exist (for example, Garbage Collector has unloaded them), you will see a pink map. But you have a black map.
The features you listed cannot affect this.

This problem should be debugged on the device on which it appears.
What I would check first:
- Whether the map appears when you change the location or zoom.
- Checked the state and existence of texture of tiles.
- Tried to destroy the map (runtime) and create it again from the prefab.

Kind Regards,
Infinity Code Team.

Do not know the best way to thank the developer? Rate the asset in Asset Store!

Re: Black map on restart

Okay, I'll tell our iOS team to try that. Thanks!