151 (edited by GamePyro.com 2018-11-25 05:23:21)

Re: Some Problems

yes but nothing changed same terreins etc RWT generated so why no coordinates error ? when i changed nothing onyl opened project. also when generated all terrains etc new nott regenertae same problem still.


and found the problem i send screenshto with edges now at genrration it say adjust edges could it be that ?



Has it something todo with new Unity 2018 and VS Pro because need install Jobs, Burst etc systems before it worked i try remove it that helps but i need both in same prtoject : OR RWT has problems with .NET 4.0 ?


Removed all the Problem is RWT not work right with .NET 4-.0  but its needed for new VS Pro at Unity 2018


So you can add .NET 4.0 support and later VS / Vegetation Studip Pro support

Regards

Re: Some Problems

I do not know what you are doing and at what step you get errors.
Please give me step-by-step instructions on how to reproduce the problem so that I can test it.

and found the problem i send screenshto with edges now at genrration it say adjust edges could it be that ?

Unfortunately, I did not understand your question.
Please rephrase that.

RWT tested up to Unity 2018.3 b10.
I just checked RWT for .NET 4.0, and it works correctly.
And there should be no problems because .NET has backward compatibility.

Kind Regards,
Infinity Code Team

Re: Some Problems

Alex Vertax wrote:

I do not know what you are doing and at what step you get errors.
Please give me step-by-step instructions on how to reproduce the problem so that I can test it.

and found the problem i send screenshto with edges now at genrration it say adjust edges could it be that ?

Unfortunately, I did not understand your question.
Please rephrase that.

RWT tested up to Unity 2018.3 b10.
I just checked RWT for .NET 4.0, and it works correctly.
And there should be no problems because .NET has backward compatibility.


But when i change back net 3.5   the download problem is  gone  it has something todo that when change to .net 4.0 it has coordinates etc problems have no point . or , gor comma / dezimals.

etc  is there any settings that need changed to work in net 4.0 ?


tested in 10 project in exiszing , new and also reimport etc always this download problem.

but only when .net 4.0

also vs pro + jobs + burst + collectins + mathematics + post processing

Re: Some Problems

I think I found a problem.
I don't know why it worked correctly for the first time.
Most likely this is some kind of bug in Unity Editor when switching the framework version.

The problem is that .NET v4.x uses CurrentCulture instead of InvariantCulture to convert numbers to strings and back.

The problem has been fixed.
I need a little more time to make sure that I fixed it in all the places where it is needed.
Most likely the new version will be available in 24 hours.

Thank you for reporting this issue.

Kind Regards,
Infinity Code Team