Topic: Buildings script not showing all buildings.

I am trying to render the buildings in residential areas outside of Los Angeles, to the south east. In areas of large factories and shopping centers, this works. However when I get into residential areas, with high density, single story homes, I don't see the textured boxes.

I have tried to lower the Floor Height and Min Building Height, in an attempt to reduce the demand of rendering, as well as increasing the maps cache, but nothing appears to work.

I am using Google Maps as my provider, with the terrain type.

Are there limitations to this feature, that may be causing this issue?
Are there better providers to get 3D building data?

Re: Buildings script not showing all buildings.

Hello.

Please send screenshots of Online Maps and Online Maps Buildings components.

Kind Regards,
Infinity Code Team.

Do not know the best way to thank the developer? Rate the asset in Asset Store!

Re: Buildings script not showing all buildings.

Thanks I sent an email with an attached .png, which displays my current settings for online maps.

Re: Buildings script not showing all buildings.

These houses are not marked on Open Street Map:
https://www.openstreetmap.org/#map=17/3 … p;layers=N

Kind Regards,
Infinity Code Team.

Do not know the best way to thank the developer? Rate the asset in Asset Store!

Re: Buildings script not showing all buildings.

OK. So the building data is sourced from Open Street Map, yes?

That being the case, in future I'll check that map site if I see other areas where buildings are not rendering to see if there is data there at in the first place.

Thanks.

Re: Buildings script not showing all buildings.

Yes, Open Street Map data is used to generate buildings.

Kind Regards,
Infinity Code Team.

Do not know the best way to thank the developer? Rate the asset in Asset Store!